Deisigh Earráid: Is cosúil go bhfuil an síneadh MySQL atá ag teastáil ó WordPress in easnamh ar do shuiteáil PHP

"Is cosúil go bhfuil an síneadh MySQL atá de dhíth ar WordPress ag teastáil ó do shuiteáil PHP“Is botún é atá ag go leor úinéirí blag agus suíomhanna Gréasáin WordPress.
Ní cúis imní é seo. Easpa síneadh MySQL Tá PHP tipiciúil de chórais oibriúcháin atá suiteáilte ón tús, VPS nó freastalaithe tiomnaithe, áit nach raibh síntí PHP mar chuid den phacáiste suiteála. Tá an fhadhb seo i láthair ar an dá cheann ubuntu agus an CentOS. Sa chás seo, réitítear an fhadhb go simplí le nuashonrú PHP agus suiteáil modúl "php-mysql".
Nuashonraigh PHP agus suiteáil síneadh MySQL ar Ubuntu

apt-get update
apt-get install php-mysql

Nuashonraigh PHP agus suiteáil síneadh MySQL ar CentOS

yum update
yum install php70w-mysql

Tar éis na céime seo, seirbhís Apache a atosúnginx.

Tháinig mé ar an scéal freisin, cé go bhfuil síneadh MySQL ann i PHP, léirigh blag a cruthaíodh ar WordPress an earráid "Is cosúil go bhfuil do shuiteáil PHP in easnamh ar an síneadh MySQL atá ag teastáil ó WordPress". An chuid is mó den am, tarlaíonn an earráid agus WordPress á shuiteáil. An uair seo, áfach, bhí sé le feiceáil ar bhlag a bhí gníomhach le roinnt blianta.
Sa chás seo, fuair mé amach nach modúil PHP an fhadhb, ach an leagan an-sean de WordPress, nach bhfuil comhoiriúnach le PHP 7.4.4RC1 a thuilleadh. Réitigh uasghrádú simplí WordPress go dtí an leagan is déanaí an earráid.

Deisigh Earráid: Is cosúil go bhfuil an síneadh MySQL atá ag teastáil ó WordPress in easnamh ar do shuiteáil PHP

Maidir leis an údar

Stealth

Paiseanta faoi gach rud a chiallaíonn gadget agus TF, scríobhaim le pléisiúr ar stealthsettings.com ó 2006 agus is breá liom rudaí nua a aimsiú leat faoi ríomhairí agus macOS, córais oibriúcháin Linux, Windows, iOS agus Android.

Leave a Comment